Technical difficulties on Proton VPN Browser Extension
Incident Report for Proton Services Status
Resolved
The fix has been deployed across all servers, and the Proton VPN Browser extensions are now again operative. We apologize for the inconvenience.
Posted Mar 11, 2024 - 18:06 CET
Monitoring
A fix has been implemented and we are progressively rolling it out.
Posted Mar 11, 2024 - 16:53 CET
Update
We are continuing to work on a fix for this issue.
Posted Mar 11, 2024 - 15:50 CET
Identified
The issue has now been identified and our team is working on a solution. We apologize for the inconvenience.
Posted Mar 11, 2024 - 14:58 CET
Investigating
We are currently experiencing technical difficulties affecting some of our Proton VPN Browser Extension users. We are working to fully restore services as soon as possible. We apologize for the inconvenience.
Posted Mar 11, 2024 - 14:52 CET
This incident affected: Proton VPN (Browser Extensions).