We've fixed a brief issue that caused intermittent connection errors for some Proton users. No user data was affected and no emails were lost, and all services are operating normally. We apologize for any inconvenience.
Posted Jun 16, 2026 - 15:18 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 16, 2026 - 14:38 CEST
Update
We are continuing to investigate this issue.
Posted Jun 16, 2026 - 14:27 CEST
Investigating
The team is currently investigating some intermittent connection issues reported by a few of our users for Proton Drive and Mail. We will share any updates here. We apologize for the inconvenience.
Posted Jun 16, 2026 - 14:27 CEST
This incident affected: Proton Mail (Web Application) and Proton Drive (Web Application, Mobile and Desktop Apps).