Server outage on ProtonVPN servers in Russia
Incident Report for
Proton Services
Resolved
This incident has been resolved
Posted
Feb
28
,
2023
-
13:53
CET
Investigating
Proton VPN servers in Russia are currently unavailable. We are working with the upstream datacenter in order to solve the issue as soon as possible.
We apologize for the inconvenience.
Posted
Feb
28
,
2023
-
08:30
CET
×
Subscribe to Incident
Subscribe to updates for
Server outage on ProtonVPN servers in Russia
via . You'll receive .