Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 06, 2025 - 11:59 CET
Scheduled
Some Proton VPN servers in Netherlands are currently unavailable. We are working with the upstream datacenter in order to solve the issue as soon as possible. We apologize for the inconvenience.
Posted Jan 06, 2025 - 11:58 CET
This scheduled maintenance affected: Proton VPN (Regular Servers).