Technical difficulties
Incident Report for Proton Services Status
Resolved
This incident has been resolved.
Posted May 28, 2024 - 18:20 CEST
Update
We are continuing to investigate this issue.
Posted May 28, 2024 - 18:02 CEST
Update
We are continuing to investigate this issue.
Posted May 28, 2024 - 18:01 CEST
Investigating
We are currently experiencing intermittent network issues affecting some of our Proton Mail web users. We are working to fully restore services as soon as possible. We apologize for the inconvenience.
Posted May 28, 2024 - 17:51 CEST
This incident affected: Proton Mail (Web Application, Incoming Mail, Outgoing Mail, Bridge, Mobile Apps, Push Notifications, Desktop Apps).