A power cut in an upstream datacenter affected some of our Swiss servers. It has been resolved and we are proceeding with restoring the most critical servers.
Posted Jun 25, 2026 - 00:58 CEST
Identified
One of our providers is currently experiencing a partial outage, affecting some of our CH server fleet. The service remains otherwise operational, and we are working on a solution.
Posted Jun 24, 2026 - 23:41 CEST
This incident affected: Proton VPN (Regular Servers).