Technical Difficulties
Incident Report for Proton Services Status
Resolved
This incident has been resolved.
Posted Mar 31, 2023 - 10:40 CEST
Update
We are undergoing a maintenance cycle and replacement for some of the ProtonVPN servers in the US. By extending our capacity we will introduce many new servers per country. We apologize for the inconvenience during this period.
Posted Mar 10, 2023 - 12:06 CET
Update
We are continuing to work on a fix for this issue.
Posted Feb 27, 2023 - 18:24 CET
Identified
We are aware of some performance issues in some of the Proton VPN servers in the US, UK, CA, and CH. We are adding more servers over the next few days to adjust to the new demand. We apologize for any inconvenience.
Posted Feb 27, 2023 - 18:20 CET
This incident affected: Proton VPN (Free servers, Regular Servers).