Technical difficulties
Incident Report for Proton Services Status
Postmortem

We apologize for the continued issues. We have unfortunately encountered an undocumented bug in Redis, an open source software that Proton runs in the backend.

For those interested in the technical details, the issue we are facing is similar to the one that caused issues at Gitlab at the end of last year: https://about.gitlab.com/blog/2022/11/28/how-we-diagnosed-and-resolved-redis-latency-spikes/. It's the same bug and we're following the same approach to address the issue permanently and as quickly as possible.

Posted May 08, 2023 - 18:47 CEST

Resolved
Earlier today we experienced technical difficulties affecting some of our Mail, Calendar, and Drive users.

All Proton services are now back to normal. The issue was resolved at 5:10 PM CEST on May 8, 2023. We apologize for the inconvenience. We confirm no emails or other data have been lost.
Posted May 08, 2023 - 17:00 CEST