Partial outage on ProtonVPN servers in Miami
Incident Report for Proton Services Status
Resolved
This incident has been resolved.
Posted Jun 04, 2024 - 09:59 CEST
Investigating
Several Proton VPN servers in Miami are currently unavailable. We are collaborating with the upstream datacenter to resolve the issue as quickly as possible. We apologize for any inconvenience caused
Posted Jun 04, 2024 - 08:47 CEST
This incident affected: Proton VPN (Regular Servers).