Mail delivery issues
Incident Report for Proton Services
Resolved
Proton Mail delivery is now back to normal. We apologize for the inconvenience. We confirm no emails or other data have been lost, but some may still be delayed.
Posted Jul 06, 2023 - 17:28 CEST
Update
We are still experiencing issues with mail delivery. All Proton teams are fully engaged in restoring the service's performance. Some emails may be delayed, but they will be delivered. No data will be lost.
Posted Jul 06, 2023 - 17:12 CEST
Investigating
Currently, we are experiencing issues with mail delivery. We are looking into it and hope to provide a fix soon. Some emails may be delayed, but they will be delivered.
Posted Jul 06, 2023 - 16:47 CEST
This incident affected: Proton Mail (Incoming Mail, Outgoing Mail) and SimpleLogin.