Proton VPN servers in Myanmar scheduled maintenance

Incident Report for Proton Services

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 10:07 CEST

Investigating

Proton VPN servers in Myanmar are under maintenance.
This is a scheduled maintenance, we apologize for the inconvenience.
Posted Apr 08, 2025 - 18:36 CEST
This incident affected: Proton VPN (Regular Servers).