Proton Wallet Technical Difficulties
Incident Report for
Proton Services
Resolved
This has now been resolved.
Posted
Apr
22
,
2025
-
18:36
CEST
Identified
We are currently experiencing issues related to a Proton Wallet deploy, causing a brief downtime. We have identified the root cause and are working on a hotfix. Thank you for your patience.
Posted
Apr
22
,
2025
-
15:21
CEST
This incident affected: Proton Wallet.
×
Subscribe to Incident
Subscribe to updates for
Proton Wallet Technical Difficulties
via . You'll receive .