Connectivity issues affecting users connecting from Russia
Incident Report for Proton Services
Resolved
This incident has been resolved.
Posted Sep 25, 2024 - 14:19 CEST
Investigating
We are working on a fix to circumnavigate restrictions. Thank you for your patience!
Posted Sep 24, 2024 - 23:08 CEST
This incident affected: Proton VPN (Free servers, Regular Servers, Secure Core Servers, Streaming, Mobile and Desktop Apps, Browser Extensions, protonvpn.com Website).