Technical problems with Secure Core servers
Incident Report for Proton Services Status
Resolved
This incident has been resolved.
Posted Mar 17, 2023 - 08:42 CET
Identified
We are currently experiencing technical problems with the Secure Core servers, affecting some of our users. We have identified the problem and implemented a fix, which should resolve the issues for everyone in the next couple of hours.
Posted Mar 15, 2023 - 13:44 CET
This incident affected: Proton VPN (Secure Core Servers, Mobile and Desktop Apps).