Technical difficulties
Incident Report for Proton Services Status
Resolved
The performance issue some of SimpleLogin users experienced has been fixed as of 4.30 pm CEST. We apologize again for the inconvenience. We can confirm no emails have been lost, but some may be delayed.
Posted Jul 28, 2023 - 16:32 CEST
Identified
We have now identified the cause of the issue, and we are taking necessary steps to try and fix it. We can confirm that no emails have been lost, but some may be delayed.
Posted Jul 28, 2023 - 16:21 CEST
Update
We apologize for the current situation. We are continuing to investigate this issue. We’ll continue sharing updates here as they happen.
Posted Jul 28, 2023 - 15:47 CEST
Investigating
We are currently experiencing technical difficulties affecting some users of SimpleLogin. Our team is investigating and working to fully restore services as soon as possible. We apologize for the inconvenience.
Posted Jul 28, 2023 - 15:11 CEST
This incident affected: SimpleLogin.