Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2025 - 07:00 CEST
Scheduled
Proton VPN servers in Comoros, Kuwait, Libya, Mauritius, Saudi Arabia, Sudan, Ghana and Ivory Coast will be under maintenance. This is a scheduled maintenance, we apologize for the inconvenience.
Posted Jun 30, 2025 - 13:42 CEST
This scheduled maintenance affected: Proton VPN (Regular Servers).