Connectivity issues for UAE users accessing Proton VPN servers via DU Telecom ISP

Incident Report for Proton Services

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 08, 2025 - 12:34 CEST

Investigating

We are currently investigating this. Thank you for your patience.
Posted Apr 06, 2025 - 13:53 CEST