Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 04, 2024 - 08:00 CEST
Scheduled
On April 4th, between 8.00 and 9.00 AM CEST (2.00 and 3.00 AM EST), we'll conduct scheduled maintenance to strengthen our infrastructure. During this time about 19% of all Proton Drive users won't be able to use the service for 5-10 minutes (Proton Drive will be read-only during this time). We're grateful for your understanding!
Posted Apr 01, 2024 - 17:24 CEST
This scheduled maintenance affected: Proton Drive (Web Application, Mobile and Desktop Apps).