Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 23, 2024 - 08:00 CET
Scheduled
On December 23rd, between 8:00 am and 9:00 am CET (7.00 and 8.00 am UTC; 2.00 and 3.00 am EST), we'll conduct scheduled maintenance to strengthen our infrastructure.
For up to 1 minute during this time, Proton Pass and Proton Docs will be unavailable. Additionally, about 10.5% of Proton Mail users will experience availability issues (their inbox will appear read-only) for up to 2 minutes.
Thank you for your understanding!
Posted Dec 20, 2024 - 11:19 CET
This scheduled maintenance affected: Proton Mail (Web Application, Incoming Mail, Outgoing Mail, Bridge, Mobile Apps, Push Notifications, Desktop Apps), Proton Drive (Web Application, Mobile and Desktop Apps), and Proton Pass (Mobile Apps, Browser Extensions).