Performance issues with the Proton VPN servers in the UAE

Incident Report for Proton Services

Resolved

This incident has been resolved.
Posted Mar 17, 2023 - 08:39 CET

Investigating

We are aware of some performance issues with the Proton VPN servers in the UAE. We are working in order to solve the issue as soon as possible.
We apologize for any inconvenience.
Posted Mar 13, 2023 - 11:19 CET