Outage on ProtonVPN servers in Norway
Incident Report for Proton Services
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 14:16 CEST
Investigating
Proton VPN servers in Norway are currently unavailable. We are working with the upstream provider in order to solve the issue as soon as possible. We apologize for the inconvenience.
Posted Sep 26, 2024 - 18:15 CEST
This incident affected: Proton VPN (Regular Servers).