Cloudflare outage

Incident Report for Proton Services

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:52 CET

Identified

We are currently investigating ways to remedy the global Cloudflare outage.
Posted Nov 18, 2025 - 14:56 CET
This incident affected: proton.me Website and Proton VPN (protonvpn.com Website).