Technical difficulties
Incident Report for Proton Services Status
Resolved
This incident was resolved at 11:11 am CET May 30th. We apologize for the inconvenience. We confirm no data has been lost.
Posted May 30, 2023 - 11:14 CEST
Investigating
We are currently experiencing technical difficulties affecting some of our users. We are working to fully restore services as soon as possible. We apologize for the inconvenience.
Posted May 30, 2023 - 11:10 CEST
This incident affected: Proton Mail (Web Application, Incoming Mail, Outgoing Mail, Bridge, Mobile Apps, Push Notifications), Proton Calendar (Mobile Apps, Web Application), and Proton Drive (Web Application, Mobile and Desktop Apps).