Technical difficulties
Incident Report for Proton Services
Resolved
This incident has been resolved.
Posted Jun 12, 2024 - 16:28 CEST
Update
We are continuing to investigate this issue.
Posted Jun 12, 2024 - 16:03 CEST
Investigating
We are currently experiencing technical difficulties affecting some of our Proton Mail users. We are working to fully restore services as soon as possible. We apologize for the inconvenience
Posted Jun 12, 2024 - 16:03 CEST
This incident affected: Proton Mail (Web Application, Incoming Mail, Outgoing Mail, Bridge, Mobile Apps, Push Notifications, Desktop Apps).