We are continuing to monitor for any further issues.
Posted Jan 20, 2025 - 12:06 CET
Update
We are continuing to monitor for any further issues.
Posted Jan 19, 2025 - 12:25 CET
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 19, 2025 - 11:35 CET
Investigating
Coinciding with the TikTok and CapCut ban in the US, we're having a spike of connections and traffic towards our services. Our tech team is working to ensure that loads are balanced, making sure the experience is smooth for everybody. Additionally, we have had reports of widespread internet issues (non-VPN related) in resolving tiktok.com outside of the US. Our team is ensuring DNS resolution works at all time for Proton VPN users.
Posted Jan 19, 2025 - 11:34 CET
This incident affected: Proton VPN (Free servers).