Proton VPN servers in Moldova outage
Incident Report for Proton Services Status
Update
We are continuing to investigate this issue.
Posted Nov 10, 2022 - 12:56 CET
Investigating
Proton VPN servers in Moldova are currently unavailable. We are working with the upstream datacenter in order to solve the issue as soon as possible. We apologize for the inconvenience.
Posted Nov 10, 2022 - 12:54 CET
This incident affects: Proton VPN (Regular Servers).