Proton VPN servers in Lithuania are experiencing network connectivity issues

Incident Report for Proton Services

Resolved

This incident has been resolved.
Posted Aug 19, 2024 - 12:57 CEST

Investigating

Proton VPN servers in Lithuania are experiencing network connectivity issues. We are working with the upstream provider to resolve this.
We apologize for the inconvenience!
Posted Jul 19, 2024 - 18:32 CEST
This incident affected: Proton VPN (Regular Servers).