Technical difficulties
Incident Report for Proton Services Status
Postmortem

Our engineering team found a concurrency limit in our server-side applications that was causing sporadic slow responses or unavailability errors for the mail, calendar, and drive applications. A permanent fix was deployed today at 5:32pm CET. In addition to resolving this issue, application performance has been improved by 30%. Proton is fully committed to continuously improving our service quality and build a better Internet.

Posted Mar 21, 2023 - 18:16 CET

Resolved
As of 5.32 pm CET all our services are fully operational for all our users. Thank you for bearing with us. We confirm that no data or emails have been lost, and apologize for the inconvenience.
Posted Mar 21, 2023 - 17:42 CET
Update
The issue is now impacting only 0.25% of users on the Proton Mail, Proton Calendar and Proton Drive web apps, as well as Proton Mail Bridge. Engineering teams are working to fully eliminate the impact. We confirm no data or emails have been lost, and we apologize for the inconvenience.
Posted Mar 21, 2023 - 17:38 CET
Update
For the last 15 minutes the issue has been impacting only 0.7% of users on the Proton Mail, Proton Calendar and Proton Drive web apps, as well as Proton Mail Bridge. Engineering teams are working to fully eliminate the impact. We confirm no data or emails have been lost, and we apologize for the inconvenience.
Posted Mar 21, 2023 - 17:00 CET
Update
The impact of the issue has been reduced to 1% of the users using the Proton Mail, Proton Calendar, and Proton Drive web apps, as well as the Proton Mail Bridge. Engineering teams are working to fully eliminate the impact. We confirm no data or emails have been lost, and we apologize for the inconvenience.
Posted Mar 21, 2023 - 16:35 CET
Identified
Proton is currently facing an overload. Engineering teams are working on it to mitigate the impact. The issue is only affecting our web apps (Proton Mail, Proton Drive, Proton Calendar) and the Proton Mail Bridge app.

We confirm no data or emails have been lost. The impact of the issue has been reduced to 5% of the users using the above listed apps.
Posted Mar 21, 2023 - 16:08 CET
Update
We are continuing to investigate this issue.
Posted Mar 21, 2023 - 16:02 CET
Update
We are continuing to investigate this issue.
Posted Mar 21, 2023 - 16:01 CET
Investigating
We are currently experiencing technical difficulties affecting about 10% of our Proton Mail, Proton Calendar, and Proton Drive users on web apps. We are working to fully restore services as soon as possible. We apologize for the inconvenience.
Posted Mar 21, 2023 - 15:59 CET
This incident affected: Proton Mail (Web Application, Incoming Mail, Outgoing Mail, Bridge, Mobile Apps, Push Notifications), Proton Calendar (Mobile Apps, Web Application), Proton Drive (Web Application), and Proton VPN (Regular Servers).