Scheduled Proton Mail maintenance, September 26th
Scheduled for Sep 26, 08:00 - 09:00 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 23, 2024 - 20:38 CEST
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 23, 2024 - 20:37 CEST
Scheduled
On Thursday, September 26th, between 8:00 am and 9:00 am CEST (6:00 and 7:00 am UTC, and 2:00 and 3:00 am EST), we'll conduct scheduled maintenance to strengthen our infrastructure. For up to 3 minutes, 0.5% of Proton Mail may experience availability issues, such as a read-only mailbox. All emails will be preserved and delivered after the maintenance window is complete.
Posted Sep 23, 2024 - 20:36 CEST
This scheduled maintenance affects: Proton Mail (Web Application, Incoming Mail, Outgoing Mail, Bridge, Mobile Apps, Push Notifications, Desktop Apps).